Проблемы с подключением

Owl_UA
Дата: 09.03.2004 15:48:46
Есть проблема - поставил из дистрибутива RedHat встроеный в него PostgreSQL, запустил службу, пытаюсь подсоединиться к серверу через pgAmin (порт 5432) - пишет, что сервер не найден... Я что-то забыл сделать?
акуз-любитель pg
Дата: 09.03.2004 17:00:10
весьма информативно

штатные телепаты, помогли бы парню что-ли )))
Sad Spirit
Дата: 09.03.2004 17:53:15
Owl_UA
Я что-то забыл сделать?

Прочитать документацию?..

Или на худой конец процитировать точное сообщение об ошибке, а не "пишет, что сервер не найден..."
Owl_UA
Дата: 09.03.2004 18:15:06
Вот что пишет:
Connection refused
Is the server running on host "192.168.0.1" and accepting TCP/IP connections on port 5432?
Sad Spirit
Дата: 09.03.2004 19:48:32
Ну и? Сервер запущен? Проверял? Как проверял?

tcp/ip слушает? По умолчанию-то не слушает, надо либо через локальный socket соединяться, либо включать tcp/ip (параметр tcpip_socket в postgresql.conf).
Genady
Дата: 10.03.2004 10:38:17
Не уверен конечно, но что то мне кажется по стилю вопроса, товарищ в pg_hba.conf ничего не прописывал.
Sad Spirit
Дата: 10.03.2004 13:02:36
от pg_hba.conf другое сообщение об ошибке
YF
Дата: 10.03.2004 17:20:44
Поробуй при запуске постмастера добавить опцию -i
Owl_UA
Дата: 15.03.2004 14:07:33
2 All
Спасибо, с TCP/IP - помогло, я новичек в постгресе, и думал, что там все необходимые фичи по умолчанию включены для работы с нуля... Ошибся...
vadimm
Дата: 14.10.2005 18:08:34
а если postgres 8.0 на SUSE 10
в pg_hba.conf разрешили уже всё всем и отовсюду
в postgresql.conf listen_address='*'
а из локалки ни в какую не подконнектится ?