Глюк с полем со списком?

-GL-
Дата: 18.09.2005 18:09:14
Не могу разобраться с глюком. Есть поле со списком, не связанная ни с чем, т.е. в свойстве "данные" - пусто. Глюк состоит в том, что бывают случаи, когда после выбора определенного значения из списка, это самое значение не отображается в поле. Точнее оно появляется на долю секунды и потом сразу же исчезает. Причем как значение оно там остается, только не отображается ! (потому как, потом я это значение проверяю)
Я проверял, мои процедуры обработки событий 100% не делают этого. В чем же дело? Может кто-то уже сталкивался с этим?
Rivkin Dmitry
Дата: 18.09.2005 18:30:56
Покажи запрос ControlSource), который сидит на этом контроле, ColumnsCount and ColumnWidths
smi
Дата: 18.09.2005 20:46:52
Попробуй поэкспериментировать со свойством присоединенный столбец.
N_A
Дата: 18.09.2005 23:27:07
У меня было,и это именно глюк. Бывало, когда в связанной форме источник строк не содержал ни одной записи, то в свободном поле со списком исчезало выбранное сначение. (причем с теми же симптомами.)
Latuk
Дата: 19.09.2005 11:49:27
Если этот глюк сильно раздражает
то поробуй поверх свободного поля со списком
расположить обычный текстбокс
в его данных указать =МоеПолеСоСписком.Column(КоторыйНадоПоказывать)
при получении фокуса текстбоксом передавать фокус
в спрятанный под него комбобокс
medium
Дата: 19.09.2005 16:47:24
Сталкивался. Вопрос - комбобокс в области данных или заголовке формы?
AlexanderYu
Дата: 03.07.2007 19:34:05
У меня такая же проблема.
combobox находится в области данных.
AlexanderYu
Дата: 04.07.2007 10:04:42
К тому же в этом же проекте есть другие формы, на которых все работает нормально!!!
Неужели никто с этим не сталкивался?
Compositum
Дата: 04.07.2007 10:08:12
AlexanderYu
К тому же в этом же проекте есть другие формы, на которых все работает нормально!!!
Неужели никто с этим не сталкивался?

попробуйте удалить поле со списком и создать новое. Мне в ряде случаев это помогло.
AlexanderYu
Дата: 04.07.2007 10:43:52
Compositum
AlexanderYu
К тому же в этом же проекте есть другие формы, на которых все работает нормально!!!
Неужели никто с этим не сталкивался?

попробуйте удалить поле со списком и создать новое. Мне в ряде случаев это помогло.

Не помогло. :(
Может быть что-то такое особенное установлено в свойствах формы?