Не стартует экземпляр

LPV
Дата: 11.08.2005 11:02:37
Сервак Windows 2003 SP1
oracle 9.2.0.7.0
сервисы oracle запускаються под доменным пользователем (админ сервера и входит в группу ORA_DBA), назовем его
admin домен domen.local, в строке под кем пускать записан как admin@domen.local.
Все работало долго и счастливо.
Когда в очередной раз перегрузили сервер экземпляр не стартанул, отписал
в oradim.log
Thu Aug 11 15:56:40 2005
ORA-12631: Username retrieval failed
и в sqlnet.log

***********************************************************************
Fatal NI connect error 12631, connecting to:
 (DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oraclesrch8)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))'))(CONNECT_DATA=(SID=srch8)(CID=(PROGRAM=C:\oracle\ora92\bin\oradim.exe)(HOST=SRV-SEARCH)(USER=Admin_Test01))))

  VERSION INFORMATION:
	TNS for 32-bit Windows: Version 9.2.0.7.0 - Production
	Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 9.2.0.7.0 - Production
  Time: 11-AUG-2005 15:56:40
  Tracing not turned on.
  Tns error struct:
    ns main err code: 12631
    TNS-12631: Username retrieval failed
    ns secondary err code: 0
    nt main err code: 0
    nt secondary err code: 0
    nt OS err code: 0
содержание sqlnet.ora
SQLNET.AUTHENTICATION_SERVICES= (NTS)
NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

если сервис стартовать под доменным пользователем введенным как DOM\admin? то все работает, так же все работает если пользователь admin@domain.local и в sqlnet.ora закоментарить строку
#SQLNET.AUTHENTICATION_SERVICES= (NTS)
или поставить параметр NONE

помогите разобраться в проблеме
mykolka
Дата: 11.08.2005 17:09:43
шото у меня складывается впечатление что у вас ДНС перенастраивали, ищи там. Как мне кажется :-)
LPV
Дата: 12.08.2005 11:52:23
не уверен что в DNS? да и сетевики клянуться что ничего не делали.
(если я неправ в какую все же сторону смотреть в DNS)
другой сервак Windows 2003 SP1 oracle 9.2.0.6.0 все работает (подсеть даже одна)
еще один Windows 2003 без SP oracle 9.2.0.5.0 тоже все работает