Нужна срочно помощь!!!

CD
Дата: 01.08.2005 16:17:52
Если честно, то я ничерта не понимаю в оракле, но т.к. сейчас время отпусков, то на меня возложили кучу обязанностей. Вот и большие дяди решили обновить базу. прислали дамп. поробовал его загрузить и нифига! у них версия 9, кажется, а у нас 8.5 вроде как. Так вот времени несколько дней, а дальше репрсии!!!
выдает сообщение:

imp-0013 only a DBA can import a file exported by anothe DBA
imp-0021 operating system error - error code <dac 2, hex 0x2>

Вот вроде и все. Прошу ответьте как можно скорее. Буду очень признателен!
vitalych
Дата: 01.08.2005 16:22:32
CD
imp-0013 only a DBA can import a file exported by anothe DBA


1. Под кем импортируется дамп? (SYS, SYSTEM, etc)
2. Попробуй дать пользователю, под которым заливаешь привилегию IMP FULL DATABASE
3. Поробуй использовать импорт под fromuser touser
RedPank
Дата: 01.08.2005 16:23:26
IMP-00013 only a DBA can import a file exported by another DBA
Cause: The privileges needed to Import an export file generated by a database administrator do not exist. Only a database administrator can import such files.
Action: Ask the database administrator to do the import.

Прав не хватает.
vitalych
Дата: 01.08.2005 16:23:31
vitalych
Поробуй использовать импорт под fromuser touser


при этом imp userid=SYSTEM/...
Vint
Дата: 01.08.2005 16:24:58
И что ето ему даст он же написал что у него версияю 8 а у больших дядей 9 вот у него ничего и не получитсься, пока дамп не будет версии ниже или равен версии у него, так что ему надо разобраться сначала с версией
whoami
Дата: 01.08.2005 16:26:31
connect / as sysdba --подключаемся к бд куда вливаем данные
grant dba to пользователь --- назначаем роль dba пользователю кот. будет осуществлять импорт данных

далее выполяем импорт
vitalych
Дата: 01.08.2005 16:30:43
Vint
И что ето ему даст он же написал что у него версияю 8 а у больших дядей 9 вот у него ничего и не получитсься, пока дамп не будет версии ниже или равен версии у него, так что ему надо разобраться сначала с версией
В данном случае проблема не в версии.

whoami
connect / as sysdba --подключаемся к бд куда вливаем данные
grant dba to пользователь --- назначаем роль dba пользователю кот. будет осуществлять импорт данных

далее выполяем импорт
А безопасность!!!

IMP FULL DATABASE - этой привилегии в данной ситуации достаточно
Pir
Дата: 01.08.2005 16:30:50
ещё неплохо бы убедиться что большие дяди снимали дамп утилитой 8 версии
slywebmaster
Дата: 01.08.2005 16:38:50
Pir
ещё неплохо бы убедиться что большие дяди снимали дамп утилитой 8 версии


это точно
- Note:132904.1
+-----------+--------------------------------------------------------------+
|  EXPORT   |                       IMPORT into:                           |
|   from    +--------+--------+--------+--------+--------+--------+--------+
|    \/     |   5.x  |   6.x  |  7.0.x |  7.1.x |  7.2.x |  7.3.x |  8.0.x |
+-----------+--------+--------+--------+--------+--------+--------+--------+
|  5.x 1) 2)| EXP5x  | EXP5x  | EXP5x  | EXP5x  | EXP5x  | EXP5x  | EXP5x  |
|  6.x    2)|  N/S   | EXP6x  | EXP6x  | EXP6x  | EXP6x  | EXP6x  | EXP6x  |
+-----------+--------+--------+--------+--------+--------+--------+--------+
|  7.0.x  3)|  N/S   | EXP6x  | EXP70x | EXP70x | EXP70x | EXP70x | EXP70x |
|  7.1.x  3)|  N/S   | EXP6x  | EXP70x | EXP71x | EXP71x | EXP71x | EXP71x |
|  7.2.x  3)|  N/S   | EXP6x  | EXP70x | EXP71x | EXP72x | EXP72x | EXP72x |
|  7.3.x  3)|  N/S   | EXP6x  | EXP70x | EXP71x | EXP72x | EXP73x | EXP73x |
+-----------+--------+--------+--------+--------+--------+--------+--------+
|  8.0.x  4)|  Not Supported  | EXP70x | EXP71x | EXP72x | EXP73x | EXP80x |
|  8.1.x  4)|  Not Supported  | EXP70x | EXP71x | EXP72x | EXP73x | EXP80x |
+-----------+--------+--------+--------+--------+--------+--------+--------+
|  9.0.1.x  |                    Not Supported                    |    5)  |
|  9.2.0.x  |                    Not Supported                    |    5)  |
+-----------+--------+--------+--------+--------+--------+--------+--------+
| 10.1.0.x  |                         Not Supported                        |
+-----------+--------+--------+--------+--------+--------+--------+--------+

5) Only the terminal Oracle8 release (8.0.6) was supported against an
   Oracle9i database: to export from Oracle9i and import into 8.0.6,
   use the Oracle8 export utility.

vitalych
Дата: 01.08.2005 16:46:01
Pir
ещё неплохо бы убедиться что большие дяди снимали дамп утилитой 8 версии
да причем здесь это.

Написано ж:
imp-0013 only a DBA can import a file exported by anothe DBA

to CD >> дай этому пользователю IMP FULL DATABASE, потом отпиши помогло или нет, а то мы спорить еще долго будем