Установил Delphi Rio

Damir_85
Дата: 01.09.2019 18:37:57
Здравствуйте.
Сегодня установил Delphi Rio. Ну сразу скажу , что на работе работаю с Embarcadero Delphi 2010. Операционная система там Windows XP, поэтому там она не установилась, так же как и Delphi Tokyo. Дома Windows 7, и установилось все нормально. Сразу возникает несколько вопросов:
1. Могли бы посоветовать книгу по программированию в Rio. Потому что по сравнению с 2010 очень много нововведений, и мне как то сложно сразу все понять. Появилось много компонентов. Ну или если еще такой книги нету, то хотя бы книгу по предыдущим версиям, по которой я более менее смогу понять нововведения. Также интересна тема программирования под Android. Ну а iOS и MacOs я при установке сразу отключил, они мне не интересны.
2. До какой версии можно обновить Delphi после 2010 , чтобы эта версия смогла установиться на Windows XP
rgreat
Дата: 01.09.2019 19:13:22
Начни отсюда.

https://ru.wikipedia.org/wiki/Delphi_(среда_разработки)

Потом, если не влом прочитай все whats new по всем новым версиям на сайте эмбы.
asutp2
Дата: 01.09.2019 19:52:29
Damir_85, если не планируешь уходить с Windows XP, то и версию делфи менять не стоит
Kazantsev Alexey
Дата: 01.09.2019 20:21:22
Damir_85,

XE7 точно ставилась на XP, дальше я не пробовал.
ёёёёё
Дата: 01.09.2019 21:12:57
asutp2
Damir_85, если не планируешь уходить с Windows XP, то и версию делфи менять не стоит

Глупости.
s62
Дата: 01.09.2019 21:13:52
Собранные в последних версиях Delphi программы не работают в XP, точнее, официально - поддерживаемые платформы - Windows 7 и выше.
http://docwiki.embarcadero.com/RADStudio/Rio/en/Supported_Target_Platforms
ёёёёё
Дата: 01.09.2019 21:22:17
s62
Собранные в последних версиях Delphi программы не работают в XP, точнее, официально - поддерживаемые платформы - Windows 7 и выше.
http://docwiki.embarcadero.com/RADStudio/Rio/en/Supported_Target_Platforms

Все работает.
makhaon
Дата: 01.09.2019 23:08:03
ёёёёё,

всё - нет. чаще - да.
ёёёёё
Дата: 01.09.2019 23:20:32
makhaon,

всё - не бывает.
rgreat
Дата: 02.09.2019 06:04:57
s62
Собранные в последних версиях Delphi программы не работают в XP, точнее, официально - поддерживаемые платформы - Windows 7 и выше.
http://docwiki.embarcadero.com/RADStudio/Rio/en/Supported_Target_Platforms

Официально XP не поддерживает даже сама майкрософт. Причем уже давно.
Неофициально - работает.