Где скачать FireBird 2.1.2.18118 ?

Belkin
Дата: 15.08.2012 12:11:43
Коллеги!
Дали стороннюю БД на FireBird 2.1.2.18118. Необходимо с ней разобраться. Но не могу к ней у себя на localhost подключиться, пишет:
автор
Connection authorization failure.
file C:\AVTOVES_BASE.FDB is not a valid database.

Пробовал ставить и 2.5.1 и 2.1.3 но подключиться не получается.
Возможно получиться подключиться с FireBird 2.1.2.18118, но такую версию не знаю где скачать.
Подскажите пожалуйста.
-----------
Андрей.
Dimitry Sibiryakov
Дата: 15.08.2012 12:16:14

Belkin
Возможно получиться подключиться с FireBird 2.1.2.18118

Не получится. Если база битая, то она - битая. Если база создана левым, модифицированным
сервером - то же самое.

Posted via ActualForum NNTP Server 1.5

Belkin
Дата: 15.08.2012 12:20:14
Dimitry Sibiryakov,
так они с этой базой работают до сих пор.
Единственное, что меня смущает, когда копировали файл на флешку, то не останавливали ни приложение которое с базой работает, ни сервис FB. Могло это так повлиять?
Мимопроходящий
Дата: 15.08.2012 12:24:17

Hello, Belkin!
You wrote on 15 августа 2012 г. 12:24:16:

Belkin
> когда копировали файл на флешку, то не останавливали ни
приложение
> которое с базой работает, ни сервис FB. Могло это так повлиять?

Posted via ActualForum NNTP Server 1.5

Belkin
Дата: 15.08.2012 12:32:10
Мимопроходящий,

Так подскажите как мне с такой базой начать работать.
Это только начало, потом придется с ней из SQL Server работать по DBLink. А в настоящий момент я не могу с ней из IBExpert поработать.
Может стоит попробовать с 2.1.2. Может у кого-нибудь дистрибутив завалялся или дадите ссылку.
Dimitry Sibiryakov
Дата: 15.08.2012 12:32:38

Даже своровать толком не смогли...

Posted via ActualForum NNTP Server 1.5

Belkin
Дата: 15.08.2012 12:34:32
Dimitry Sibiryakov
Даже своровать толком не смогли...

8(
Это вы про что?
Никто и ничего не ворует. Просьба обойтись без оскорблений.
PEAKTOP
Дата: 15.08.2012 12:37:06
Belkin
Так подскажите как мне с такой базой начать работать.
Это только начало, потом придется с ней из SQL Server работать по DBLink. А в настоящий момент я не могу с ней из IBExpert поработать.
Может стоит попробовать с 2.1.2. Может у кого-нибудь дистрибутив завалялся или дадите ссылку.


Там вертикальная совместимость. Качай последний Firebird 2.5 - и должно заработать.
Но то, что клиентское приложение будет с ней работать под 2.5 - никто гарантий здесь не даст.

Да и в самой базе может быть какая-нибудь примитивная защита, вроде роли SYSDBA.
Dimitry Sibiryakov
Дата: 15.08.2012 12:37:53

Belkin
Это вы про что?
Никто и ничего не ворует.

Тогда к чему такая спешка с копированием базы на ходу?.. Пусть просто отдатут тебе
последний бэкап. Они ведь делают бэкапы?..

Posted via ActualForum NNTP Server 1.5

PEAKTOP
Дата: 15.08.2012 12:41:43
Dimitry Sibiryakov
Они ведь делают бэкапы?..


=)))))

а можно я угадаю ответ ?