(PHP) Не обрабатываются скрипты *.php3

httt
Дата: 14.07.2006 07:06:49
Не воспринимаются имена name.php3. Браузр предлагает открыть файл или сохранить. Раньше на 4-ой php все работало на 5-ой не хочет.
DocAl
Дата: 14.07.2006 07:20:36
У вас в конфиге апача должна быть примерно такая строка:
AddType application/x-httpd-php .php
Добавьте после ".php" ".php3" и перезапустите апач.
httt
Дата: 14.07.2006 07:54:53
 AddType allows you to tweak mime.types without actually editing it, or to
    # make certain files to be certain types.
    #
    # For example, the PHP 3.x module (not part of the Apache distribution - see
    # http://www.php.net) will typically use:
    #
    AddType application/x-httpd-php3 .php3
    AddType application/x-httpd-php3-source .phps
    #
    # And for PHP 4.x, use:
    #
    AddType application/x-httpd-php .php3 
    AddType application/x-httpd-php-source .phps
                                                                                                               
Пробовал разные комбинации - не работает.
*
Дата: 14.07.2006 10:12:45
Апач надо ребутить после изменения настроек httpd.conf
4m@t!c
Дата: 14.07.2006 10:28:22
Модератор:
Оформляйте топики согласно требованиям форума!!! Топики оформленные не по правилам - будут удаляться.

----------------------------------------
Артисты не приехали, приехали цыгане
httt
Дата: 14.07.2006 15:38:02
Конечно ребутил. Но не помогает. Ставил из бинарников (rpm).
httt
Дата: 18.07.2006 06:42:57
Установил Postgres, php и apache. Не работает
$cnct = pg_Connect( "host=localhost port=5432 dbname=name user=postgres password=postgres" );
Ничего не выдает. Стоит:
rpm -qa |grep apache
apache-common-1.3.34rusPL30.22-alt1
apache-1.3.34rusPL30.22-alt1

rpm -qa |grep php
php-libs-4.4.2-alt0.cvs20051121.1
php-pgsql-4.4.2-alt0.cvs20051121.1
php-dba-4.4.2-alt0.cvs20051121.1
php-devel-4.4.2-alt0.cvs20051121.1
mod_php-4.4.2-alt0.cvs20051121.1
php-curl-4.4.2-alt0.cvs20051121.1
php-pcntl-4.4.2-alt0.cvs20051121.1
php-cgi-4.4.2-alt0.cvs20051121.1
php-base-2.0-alt1
php-4.4.2-alt0.cvs20051121.1
php-mcrypt-4.4.2-alt0.cvs20051121.1
Чего не хватает? После установки GNOMЕ начинает работать.
Anjey aka PM
Дата: 18.07.2006 08:41:15
а при успешном коннекте и НЕ ДОЛЖНО ничего выдавать, также как и при ошибке, если уровень сообщений об ошибках не максимальный
Alexey Lapusta
Дата: 19.07.2006 02:13:14
<?php
$connection = pg_connect("host=localhost port=5432 dbname=name user=postgres password=postgres") or die ("Error: ".pg_last_error($connection));
?>